为什么使用基础库版本2.22.1或者2.23.0, 小程序调用callContainer报错?
发布于 2 年前 作者 huangyan 8631 次浏览 来自 问答

一直使用小程序2.18.1基础库,运行正常,最近发现小程序里面调用submit的时候没有反应,开发工具中使用2.18.1, 

没有问题,但一旦换成2.22.1或者2.23.0,就会报这个错误:

导致整个过程失败。目前大家安装的微信基本库版本都比较高,导致小程序现在无法使用。

调用代码如下:

var c1 = new wx.cloud.Cloud({
      resourceEnv: 'zhuai-kouhong-7gdrcibqf13c4fd1'
    })
    c1.init()
   c1.callContainer({
      path: '/chunyin/submit', 
      data: datasubmit,
      method: 'POST',
      header: {
        'X-WX-SERVICE': 'chunyin',
        'content-type': 'application/json' 
      },
      success (res) {
        if (res.statusCode === 200) {
          wx.navigateTo({
            url: '../poster/poster'
          })
        }
      },
      fail(e) {
        console.log("submit failed")
        console.log(e)
      }
    })

查看了后台的日志,无论使用2.18.1还是2.22.1/2.23.0, 后台的输出信息和debug信息都是一样的。

调试多次,实在无解,望能解释2.18.1和2.22.1/2.23.0 基础库区别

1 回复

前端后端调查了个遍,都没有发现问题,后端开启调试模式,发现无论是2.18还是2.22.1/2.23.0, 返回都是一样的,数据库里面该插入和更新的也都对,无奈只好在微信包括后,依然跳转

      success (res) {
        if (res.statusCode === 200) {
          wx.navigateTo({
            url: '../poster/poster'
          })
        }
      },
      fail(e) {
        console.log("submit failed")
        console.log(e)

        wx.navigateTo({
           url: '../poster/poster'
        })
      }

回到顶部